GPU计算 讨论区


#87

新手学习如何使用gpu,代码路径:gpu_dropout_test.zip (5.4 KB)。
大神帮忙看下如何可以将使用gpu那一块的代码变得优美,想学习学习专业的写法!


#88

求助 kaggle 要安装那个版本的mxnet 才能用他的gpu,,,,


#89

花了两天时间卡在这里了,cuba9.2,mxnet-cu92,win10,gtx1060 6g,重装多次,各种顺序,期间把屏幕还搞黑了两次。。。但是还是不成功。。。
运行“!nvidia-smi”时正常。

运行“nd.array([1, 2, 3], ctx=mx.gpu())”时报错,为“cudaMalloc failed: device kernel image is invalid”


#90

按时捞一波


#91

安装成功了,为什么调用 “a = nd.array([1, 2, 3], ctx=mx.gpu()) ”报错???

2

报错如下:


#92

情况和我一样,5555桑心


#93

我的问题发生在台式机,就一个独立显卡,都是这样吗?


#94

不,看你显卡的等级吧,好像网上有个显卡计算能力表,3.0以上的就可以,我的机子显卡太老所以不行


#95

1060是第6.1啊 。。。


#96

那应该没问题啊,可能是cuda或者驱动之类的问题吗 你看看他们讨论的帖子。。


#97

同样的错误,请问最后解决了吗?


#99

请问为什么 labels被存放在 cpu里面?怎么解决这个问题?


#100

请问你解决这个问题了吗


#101

mxnet-cu80 == 1.3.0 也报同样的错。

应该是版本问题,目前通过以下命令

pip install mxnet-cu80==1.2.0 -i https://pypi.douban.com/simple

退回1.2.0后程序通过。

希望官方能早日解决bug。。。


#102

感谢,终于解决了,下载了好多版本,退回1.2.1都不行,还是得1.2.0。心疼流量


#103

@TX @liqiuye @wangyouming123 @Eins @pythonnoob @AnAutomaticPencil @gca @little7

感谢反馈。非常抱歉这么晚才看到。。。(下次直接 at 我吧)

更新的版本应该就可以了,例如pip install mxnet-cu92==1.5.0b20181215
或者回到1.2.0

这两天会可以post一个1.2.1.post1版本解决这个问题。可能要考虑把书里代码的dependency先改回1.2.0


#104

请问,这个问题是怎么解决的


环境:
python 3.5
CUDA Version 9.0.176
mxnet-cuda==1.4.0


#106

请问没找到支持mac.10.14版本的NVIDIA GPU该怎么办呢?


#107

您好!我使用的是10.14版本的MACOS,没找到支持的NVIDIA GPU该怎么办呢?


#108

我有一个很不明白的问题,我的电脑有两块GPU( Intel+英伟达GTX1050 ),如下:
GPU
根据NVIDIA显卡中NVCUDA的信息,如下:
2
我安装了CUDA9.2.148,并且对应卸载了原有的mxnet,并安装了mxnet-cu92,如图:
1
安装成功,但是在检测显卡信息时,却只能检测到一块显卡如下:
%E6%98%BE%E5%8D%A1%E4%BF%A1%E6%81%AF
range(0, 0)表示只有一块,而且在运行本节的例程时,确实mx.gpu()正常mx.gpu(1)则报错:
Check failed: e == cudaSuccess || e == cudaErrorCudartUnloading CUDA: invalid device ordinal
或者下面这种:
Check failed: exec_ctx.dev_id < device_count_ (1 vs. 1) Invalid GPU Id: 1, Valid device id should be less than device_count: 1
而且与此同时,发现只要在import mxnet之后,原本内存占用45%,一下子稳定保持在70%,内存占用提升很多,所以很不明白什么情况。GPU(1)即NVIDIA的GTX1050,内存利用率一直完全稳定于0%,完全没有反应,如下:
GPU1
请教各路大神帮忙看看,毕竟在后面跑LeNet例程时,一个epoch跑半分钟,而例程里只有2秒,跑50个epoch我都能睡个午觉了,真的伤不起呀!!!