获取和运行本书代码 讨论区


#104

那个错误看样子是操作系统比较旧,所以上面的glibc的支持不够,如果可能的话试下更新的linux


#105

看起来是不是用了python2?尽量用python3吧


#106

重新更新了一把gluon环境和mxnet后发现打开markdown有can’t save ascii的问题,而之前老版本的时候是没问题的,用的也是python3不知道是怎么回事?


#107

非常感谢,我用python3启动之后一切正常了!


#108

我现在也是这个问题。。。你解决了吗??怎么做的。。。


#109

我跟他一样的报错。。。但是我装的是cu90的mxnet。。。
还不知道怎么办。。。大佬,求救。。。我现在是manjaro系统。。。


#110

请问能不能录一个在window下的安装教程。文字描述根本看不懂


#111

不是已经说明了嘛…
sudo apt-get install libgfortran3
或者换成你对应系统的软件包安装命令安装libgfortran3


#112

不存在的。。。我的系统是manjaro。。。已经解决了。。。谢谢。。。


#113

昨天2017.11.26安装运行linux版mxnet遇到了一个bug,在这反馈下好了:
Windows使用CUDA8+Cudnn7的prebuilt lib(来自https://github.com/yajiedesign/mxnet/releases),
mxnet版本0.12.0
python 2.7
Ubuntu版本使用mxnet-cu80
mxnet版本0.12.1
python 2.7

windows上训练后保存的symbol.json统一使用“attrs”
而Ubuntu上则混合使用"attrs"和"attr",导致不兼容

错误信息:
mxnet JSONReader: Unknown field attrs, candidates are: “attr” “backward_source_id” “control_deps” “inputs” “name” “op” “param”


#114

conda env update environment.yml
Using Anaconda API: https://api.anaconda.org
Fetching package metadata …
Solving package specifications: .
Collecting requests
Using cached requests-2.18.4-py2.py3-none-any.whl
Collecting mxnet>=0.11.1b20171106
Could not find a version that satisfies the requirement mxnet>=0.11.1b20171106 (from versions: )
No matching distribution found for mxnet>=0.11.1b20171106

CondaValueError: pip returned an error.

Ubuntu 16.04.3 conda安装出错,


#115

使用pip install


#116

请问激活时提示系统找不到指定路径怎么解决?系统是win10


#117

是用anaconda装的吗,添加到path里了吗?
用过anaconda prompt来执行命令吗?
尝试过搜索相关问题吗?


#118

是的 用anaconda安装的 也查过了相关问题,但没有找到解决方法,试过添加环境变量,也试过anaconda prompt ,还是找不到路径,都不行才决定提问的 :disappointed_relieved:


#119

或许可以参考https://www.zhihu.com/question/58573630,能不能成功我不能保证。
Windows其实安装prebuilt libraries版本也比较简单:https://github.com/yajiedesign/mxnet/releases
另外找一找到底有没有新建py环境


#120

感谢回复 但是第一个方法还是没有解决,我看了自己的环境目录下是有新建的gluon文件夹的。
所以我想请教一下您给的prebuilt libraries 版本怎么安装?和之前那种版本有什么区别? 抱歉,实在小白 ,希望得到解答,再次感谢!:sweat_smile:


#121

具体安装教程可以参考:https://github.com/yajiedesign/mxnet/issues/21#issuecomment-334945717
使用上没有什么区别,只是安装方式不一样


#122

非常感谢!:grinning:


#123

手贱……刚换的manjaro…… 现在也是报这个错……
pacman 和 yaourt 都找不到libgfortran3,只有aur中有个6,还装不上……
现在你可解决了?