Mxnet环境下载清华源配置——记录自己遇到的下载慢问题。

在执行书本以下两条指令时:

配置清华PyPI镜像(如无法运行,将pip版本升级到>=10.0.0)

pip config set global.index-url https://pypi.tuna.tsinghua.edu.cn/simple
conda env create -f environment.yml
在我尝试安装gpu版本的mxnet时,遇到以下问题和走了一些弯路:
1、下载速度巨慢,每次下载一半总是报错(网络不稳定)。
——虽然配置了global.index的地址为清华镜像,但是需要同步将清华镜像添加到channel中。解决方案,添加配置为:
conda config --add channels https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/free/
conda config --add channels https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/main/
conda config --set show_channel_urls yes
2、修改environment.yml中的python版本到3.8,将字符串mxnet==1.5.0改为mxnet-cu80==1.5.0,重新运行conda env create -f environment.yml,结果python可以顺利安装,但是pip要安装的5个依赖项
( - mxnet-cu80==1.5.0

  • d2lzh==1.0.0
  • jupyter==1.0.0
  • matplotlib==2.2.2
  • pandas==0.23.4)
    遇到以下错误:

    看了下错误里面,有提示在各个安装包的setup.py。尝试几次不成功,怀疑可能是python版本不兼容导致。具体细节没去查看,将environment.yml文件中- python=3.8修改回- python=3.6,删掉gluon文件夹重新运行后,成功安装。

    到此,安装环境完成。这个东西前后折腾了2/3小时,走了不少弯路,做个记录,希望对大家有帮助。