求助 OSError: [WinError 126] 找不到指定的模块。

from mxnet import ndarray as nd
nd.zeros((3,4))

OSError Traceback (most recent call last)
in ()
----> 1 from mxnet import ndarray as nd
2 nd.zeros((3,4))

f:\python35\lib\site-packages\mxnet_init_.py in ()
23
24 from .context import Context, current_context, cpu, gpu
—> 25 from .base import MXNetError
26 from . import base
27 from . import contrib

f:\python35\lib\site-packages\mxnet\base.py in ()
108 version = libinfo.version
109 # library instance of mxnet
–> 110 _LIB = _load_lib()
111
112 # type definitions

f:\python35\lib\site-packages\mxnet\base.py in _load_lib()
100 “”“Load library by searching possible path.”""
101 lib_path = libinfo.find_lib_path()
–> 102 lib = ctypes.CDLL(lib_path[0], ctypes.RTLD_LOCAL)
103 # DMatrix functions
104 lib.MXGetLastError.restype = ctypes.c_char_p

f:\python35\lib\ctypes_init_.py in init(self, name, mode, handle, use_errno, use_last_error)
345
346 if handle is None:
–> 347 self._handle = _dlopen(self._name, mode)
348 else:
349 self._handle = handle

OSError: [WinError 126] 找不到指定的模块

是安装GPU版本后出现的问题吗?如果是,你手动更新下显卡的驱动,越新越好

cpu版我也遇到过这个问题。检查一下你的python环境,尝试重装python环境,然后再重新装mxnet

谢谢大家!缺少 vcomp140.dll,下载下来并放在 Python\scripts下,问题解决了

import mxnet
Traceback (most recent call last):

File “”, line 1, in
import mxnet

File “f:\python36\lib\site-packages\mxnet_init_.py”, line 25, in
from . import engine

File “f:\python36\lib\site-packages\mxnet\engine.py”, line 23, in
from .base import _LIB, check_call

File “f:\python36\lib\site-packages\mxnet\base.py”, line 111, in
_LIB = _load_lib()

File “f:\python36\lib\site-packages\mxnet\base.py”, line 103, in _load_lib
lib = ctypes.CDLL(lib_path[0], ctypes.RTLD_LOCAL)

File “f:\python36\lib\ctypes_init_.py”, line 348, in init
self._handle = _dlopen(self._name, mode)

OSError: [WinError 126] 找不到指定的模块。

到底是什么模块?我试过你的。。。不行哦。。。

cuda是9.1的版本报的错。。。后来卸载了,装9.0就好了。。。

请问cuda安装了9.1的版本那么pip命令mxnet-cu是多少?

cu91啊。。。
你可以先pip search mxnet看看都有什么东西。。。

但是pip install mxnetcu-91这个命令不支持:joy:

-U mxnet-cu91
pip安装点东西还不会?看看百度吧。。。

mxnet-cu110没有此版本如何解决,我安装的cuda是11.0的?

我是刚开始可以,过几天打开有这个错误代码,当时我翻墙了,搞了很久都不行,后来重启就好了